summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1f08b77
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "rustynotes"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[profile.release]
+opt-level = 3
+# incremental seems to allow the compiler to save autovectorization
+# info and makes the fold version autovectorize properly :o
+incremental = true
+
+[dependencies]
+alsa = "0.7.0"
+derive_more = {version = "0.99.17", features=["display"]}
+rustfft = "6.1.0"
+realfft = "3.2.0"
+# TODO: crossterm 0.25 currently because tui hasn't updated to 0.26 yet,
+# update this dependency when tui updates to 0.26
+# (added serde here, double check that doesn't break performance again)
+crossterm = { version = "0.26", features = ["serde"] }
+#tui = "0.19.0"
+# serde and larger things like clap mess with the autovectorization in the main code i think (or make runtime slower atleast), gotta explicitly vectorize and see if that helps or if it's something else going on
+# even without actually using them just including them as deps messes with it, unless they're disabling incremental linking or forcing lower opt-levels
+# weirdly building both of them with features in release gets rid of the spikes up to 4-7%, for now atleast :o, but individually they both start causing spikes :o
+# building both together did cause serde to update to 1.0.160, so maybe problems with older versions of serde or somethins
+tui = { package = "ratatui", version = "0.20.1", features = ["serde"] }
+clap = { version = "4.2.2", features = ["derive"] }
+num-traits = "0.2.15"
+serde_json = "1.0.96"
+serde = { version = "1.0.160", features = ["derive"] }
+ansi_colours = "1.2.1"